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1. Scope

This user guide describes how to use the Smartcard Manager application to configure  
rf IDEAS® readers. Readers that are capable of reading data fields from contactless cards 
require additional settings beyond our typical interfaces. 

The Smartcard Manager will inform the reader what data bytes to read and what keys are 
needed to access that data. For keystroke readers, pcProxConfig can then be used as needed 
for additional formatting of keystroke output. For SDK access and MFP24 readers, Smartcard 
Manager is the only application needed.

Card types currently supported are LEGIC® (advant and prime), MIFARE Classic®, and MIFARE 
DESFire® (EV1/EV2/LEAF). Details of the cards are not included here, it is assumed that the 
reader is aware of the data structure (blocks, files or sectors) and what keys are needed for their 
particular card. There is a brief overview of how MIFARE keys are stored and the nomenclature 
as used by Smartcard Manager.

NOTE: All numeric entries in the GUI are in hexadecimal!

2. Standard Controls

Some controls can be accesssed at all times. The Configure Reader button at the bottom will 
send configuration data (not including keys) to the reader. Next to it is the status bar, where any 
error condition will be displayed in red.

There are several menu entries, some of which deserve special mention: 

1.	  File > Save Configuration – save configuration settings, including keys, if entered, to the PC
2.	 File > Load Configuration – retrieve configuration settings from the PC
3.	 File > Start Trace Log File – captures actual USB messages to and from the reader
4.	 Options > Perform Beep Test – test the current connection by telling the reader to beep
5.	 Help > About Smartcard Manager, About Reader  – display version and other information

The Save and Load Configuration options creates a readable .ini file for all settings and keys 
that are currently set in the active tabs. To avoid saving a key in a readable format, it is 
recommended to use the Encrypt button found in the key tab before saving the configuration.
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3. General Settings

In the General Settings tab, Connect/Reconnect will establish a connection to the reader. This is useful when 
switching readers on the PC (it will only connect to one reader at a time). It reads the current configuration of 
the reader as part of the connection process.

The General Settings tab is used to configure card types, and additional tabs are used for specific MIFARE® 
or LEGIC® configuration and to send keys. The pcProxConfig utility can be used if additional settings are 
needed for specialized keystroke output, such as converting the data to decimal or ASCII output. There can 
be multiple secure file configurations set at one time, and a mix of MIFARE DESFire® EV1/EV2 and MIFARE  
Classic®. LEGIC readers do not read MIFARE secure data and vice versa.

If the same secure file data card type is selected for more than one configuration (as shown above), then 
the Card Configuration Index (1-4) in the subsequent tabs will determine which configuration is currently 
selected.
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4. LEGIC® Settings and Key

If a card type is set to LEGIC Stamp, then a tab for LEGIC Settings will appear. For firmware version 20.7 and 
later, a tab for LEGIC Key will also appear.  

The LEGIC settings tab has the following fields:

A LEGIC segment can be addressed by the Stamp Address, or by the segment number. When using the 
segment number, an optional Stamp Length field is available. Entering this will keep the data consistent if 
both LEGIC advant and prime cards are being used, as the prime card includes the stamp with the card data, 
while the advant does not.
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The Segment Card Type field is useful when using a multi-technology LEGIC® card. There are three LEGIC 
technologies: prime, advant on ISO-14443A, and advant on ISO-15693. On a multi-technology card, there 
will be a combination of technologies, each with its own range of segments, possibly using the same Stamp 
address. This field will determine which one is used, or “First Found” is non-discriminatory (default case, and 
best choice for the standard single-technology card).

For firmware versions 20.7 and later, a user-defined key number can be entered. This key number is an index 
to a table stored in the LEGIC chip. The actual key is entered in the next tab, the LEGIC Key tab.

Note that the key is not sent to the reader when the Configure Reader button is pressed. There is a separate 
Send User Key button.

The key is entered on this tab, and stored at location Key Number in the LEGIC chip. The key cannot be read 
back. If desired, the key can be encrypted after it is entered. Thereafter it will be displayed in the encrypted 
form, stored in the configuration file as encrypted (if a configuration file is created), and it is sent encrypted 
over USB to the reader

The bottom section of this tab is used for Launch (baptism) using a SAM-63 card. Some user cards require 
that a reader be launched before the user data can be read. If LEGIC Stamp is selected as a card type, than 
any LEGIC reader (including 20.5) can be launched with a SAM-63 card. 

In firmware 20.7 and later, when a SAM-63 card is detected in the field, the usual 15-second window for 
launching is reduced to 7 seconds, and a beep and/or LED change indicates the launch has occurred. This 
results in a record being stored in the LEGIC chip. This launch record can be read back, to verify it was 
launched, and it can also be deleted.
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5. MIFARE® EV1/EV2 Settings

If a card type is set to MIFARE EV1/EV2 Secure File Data, then a tab for MIFARE EV1/EV2 Settings will appear. 
Selecting it will show the following fields needed for reading a DESFire® card:

The Data Type Presets at the top are a handy way to set the reader for common uses. For example, the LEAF 
Cc and LEAF EV1 Compatible presets will fill in the fields to read the Badge ID from a standard LEAF card.  The 
other options are for more customizable data selection.  

The rest of the page is organized into three blocks:

•	 Data Location – where the data is located on the card, and what bytes to return.
•	 Encryption – how the data is protected and with what key.
•	 Signature Verification – for optional anti-cloning protection.
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Data Location: 
The MIFARE® DESFire® cards store data in Application spaces, referred to by their 
Application ID (AID). Each AID has one or more Files where the data is stored.  The AID is 
sometimes described in big endian format (most significant number first) or little endian 
format (least significan number first). Smartcard Manager uses the latter, following the 
lead of NXP tools, but card documentation may vary.

Encryption 
The Key Reference is an index into keys stored on the SAM AV2 chip inserted into the 
reader.  The Key can also be programmed at this time using the EV1/EV2 Key tab, or can 
be programmed at another time, even on a different reader or device.  In any case, the Key 
Reference value on this page must match the Key ID used when storing the key. The index 
is a value in the range of hexadecimal values 01 to 7F.

A diversified key is modified, in part by the card’s CSN, so the resulting key is unique to 
each card.
Card key number refers to which key on the MIFARE card is used for access to the data 
on this AID/File.  Typically this is 01, values can be 00 to 0D.  Card key number of 0E is 
reserved for Free Read Access (no key needed).

Key Types: 

•	 AES-128 (uses a 16 byte, 32 character key) 
•	 2KTDEA-DES (16 byte 3DES using MIFARE DESFire implementation).  

For single DES, repeat the 8-byte key.
•	 2KTDEA-ISO and 3KTDEA (3DES using ISO-10116) are  

not available in firmware version 21.3 or 21.6 

Signature Verification
This involves computing a signature from the data and comparing to a value on the card, 
using a key/process distinct from data encryption. This key used to make the signature 
is not stored on the card being read, and uses diversification, so a cloned card will fail 
the signature verification test. The Signature Verification process uses an additional key 
reference to the Originality and Cloning Protection System Key (OCPSK).

TIMING NOTE: Signature Verification requires additional data to be read and an additional 
encryption step.  On a standard LEAF Cc card for instance, it nearly doubles the read and 
response time to about 1.5 seconds.
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6. MIFARE® EV1/EV2 Key

Unless the file data is Free Access, a key will be needed to access the data.  The key is stored on the NXP 
AV2 SAM (the removable SIM card).  This key is kept separate in the reader from file configuration and other 
settings.  It is not changed if the reader is set to defaults or boot loaded with new firmware.  The keys can be 
programmed onto an AV2 SAM card on one reader, and then moved to another reader for use there.  (AV2 SAM 
cards are only recognized at power-on, so the readers will need to be unplugged when moving the cards).

For MIFARE DESFire® EV1/EV2, there are two places a key can be used, so there are two sections on this tab.  
First is Data Access. The AV2 SAM needs the AID stored with the key, so that information is duplicated from 
the EV1/EV2 Settings tab.  The second section is for OCSPK, which can use the same key value as above if 
desired.  AID is not needed for the OCPSK. Each section has its own Send button.
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7. MIFARE Classic® Settings Tab

The MIFARE Classic card is simpler than the MIFARE® DESFire® EV1/EV2.  Memory is also arranged differently, 
with sectors composed of blocks.  Typically a sector has four blocks: three data blocks, and the last block has 
key and access information.  They count from 0, so block 4 is the first data block of sector 1.  Each block has 
16 bytes, and each sector has 48 bytes of data.  

There are two keys, each 6 bytes long.  Typically Key A is used, but Key B is also possible.  The two keys fit 
into one entry in the SAM AV2.  Key ID and Key Reference values are the same as in MIFARE DESFire EV1/EV2.  
Note that the Configure Reader button at the bottom of the tab will not send the keys to the reader, the Send 
Keys button is used for that.
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Note:  The reader firmware has been extended for MIFARE Classic® to be able to keystroke up to 48 bytes 
of data (a typical sector). The SDK (API) interface, however, still has a maximum of 32 bytes. This is only 
noticeable if the configured length is more than 32 (hexadecimal 20), and the pcProxConfig utility (or similar 
application using our DLL) is used to retrieve data.  The first 32 bytes are returned, and it reports a maximum 
of 255 bits of data.

8. MIFARE® Key Storage overview

The Key ID used when storing a key must be the same value that later will be used as the Key Reference when 
reading the data.  They have a valid range of 1 to 127 (01 to 7F).  The Card Key Number is an index to the key 
stored on the card, and that is a value 0 to 13.  Card key number 14 (0E) is reserved for Free Access, and card 
key number 15 (0F) is No Access.  See the following figure for specifics on keys, using the MIFARE DESFire® 
EV1/EV2 card as an example as it is the most complicated. The same general structure is also used in LEGIC® 
systems.

Host (PC)

Running Smartcard 
Manager or similar to 
configure the reader  
(and NXP AV2 SIM card)

rf IDEAS® Reader

Store key using Key ID, 
Accessing using Key Reference 
Cannot read key back

Configuratiom file, may 
include keys, keys are 
optionally encrypted.

AV2 SIM card

Keystore:
0= Master Key (reserved)
1-127= available key space



RF communication 
between reader and card

MIFARE  Card

AID z

AID y

AID xApplication Keys
0= App. Master Key
1-13= App. File Access Key 1-13= App. File Access Key
14 (0E)= File is Free Access
15(0F)= File is locked

Card Key Number is value 0-15, 
is set for the selected AID when 
writing the card data
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